Hi, to play this game you need Adobe flashPlayer 7 or better.
Use this link to install it