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Appendix A.4:  Introduction to FEHT  
A.4.1 Introduction 
FEHT (pronounced 'feet') is an acronym for Finite Element Heat Transfer.  The basic function 
provided by FEHT is the numerical solution using finite element of 2-D steady state and 
transient heat transfer problems.  FEHT is intuitive to use and therefore can be learned very 
quickly by students and researchers.   
 
A version of FEHT that allows up to 1000 nodes is provided on 
www.cambridge.org/nellisandklein.  A commercial or professional version of FEHT can be 
obtained from: 
F-Chart Software 
http://fchart.com 
email: info@fChart.com 
 

A.4.2 Using FEHT   
A.4.2.1 Introduction 
FEHT provides three essential functions: Problem Definition, Calculations, and Output.  The 
Problem Definition commands provide a drawing environment in which the mouse is used to 
draw the outlines of the materials with straight lines; a variety of drawing aids are provided to 
facilitate this process.  Triangular elements of arbitrary size needed in the finite-element analysis 
are specified by the user by clicking the mouse button on the endpoints of the lines.  The 
program monitors the discretization process to ensure that lines do not cross.  Once a coarse 
triangular mesh is prepared manually, the program can automatically reduce the mesh size.  The 
Problem Definition is completed by specifying the boundary and (for transient problems) the 
initial conditions.  These specifications are made by double-clicking the line, node, or material 
with a mouse click (causing it to flash) and then selecting the desired specification from a pull-
down menu.   
 
Calculations are initiated from a pull-down menu.  The program first checks to see that all 
materials are properly discretized and that the properties, boundaries, and initial conditions are 
specified.  Any error detected during this process is marked and described in a separate window 
at the top of the screen.  For transient problems, the computational method (Euler or Crank-
Nicolson) and the start time, stop time and time step are selected from a dialog box; if no errors 
are detected, then the calculations are initiated. 
 
A variety of output capabilities are provided.  For steady-state problems, the potentials 
(temperature, voltages, magnetic potential, streamlines, or pressures) within the material may be 
shown at the nodal positions or in one of several types of contour plots.  The potential (e.g., 
temperature) at the cursor position is displayed when the mouse button is depressed.  The 
potential gradients (e.g., temperature gradient, current density, electrical or magnetic flux 
density) within the materials can be displayed using arrows that point in the direction of the 
gradient where the shaft length is proportional to the magnitude of the gradient.  The flow of 
heat, charge, current, or magnetic flux across any element line may be determined by clicking the 
mouse button while the cursor is on the line.  For transient heat transfer problems, the 
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temperatures of selected nodes may be displayed in a temperature versus time plot.  Heat flow 
can be plotted as a function of time.  The contours and/or temperature gradients for each time 
step may be shown in sequence providing a 'movie' depicting the changes with time. 
 
Section A.4.2.2 illustrates the solution of a simple heat transfer problem using FEHT from start 
to finish.  Reference information is available from within the program by pressing the F1 key 
which brings up the online Help program.  Section 2.7.2 (Extended Section E6, available on 
www.cambridge.org/nellisandklein) provides a summary of the finite-element method that is 
used by FEHT.  
 
A.4.2.2 Getting Started 
FEHT will run under the Microsoft Windows Operating systems.  The installation program will 
create a menu item in the Programs section of the Start menu.  Detailed help is available at any 
point in FEHT.  Pressing the F1 key will bring up a Help window relating to the foremost 
window.  Clicking the Contents button will present the Help index.  Clicking on an underlined 
word (shown in green on color monitors) will provide help relating to that subject.   
 
There are several example problems with completed problem definitions stored in the Examples 
subdirectory on the disk which can be accessed using the Open command in the File menu.  
These example problems illustrate the necessary triangular discretization and allow a review of 
the output commands after the Calculate command in the Run menu has been issued. 
 
Commands are distributed among nine pull-down menus; a brief summary of their functions 
follows:   

o The File menu provides commands for loading and saving work files, printing, and 
copying information to and from the clipboard. 

o The Subject menu allows the problem discipline to be selected from the areas of heat 
transfer, electrical currents, electrostatics, scalar magnetostatics, bio-heat transfer, 
potential flow and porous media flow .   

o The Setup menu commands allow specification of the unit system, size, scale, coordinate 
system (Cartesian or cylindrical),  and problem type (steady-state or transient). 

o The Draw menu contains the commands to outline a material, manually or automatically 
construct element lines, delete or group selected items, reposition nodes, and add text. 

o The Display menu contains a variety of commands which affect the screen display 
including a Zoom command to enlarge a selected part of the screen. 

o The Specify menu allows material properties, internal generation, boundary conditions 
and initial conditions to be specified. 

o The Run menu contains commands to check a problem definition and to initiate or 
continue the calculations. 

o The View menu provides the means to making one of the nine FEHT windows active.   
o The Examples menu provides convenient access to a number of example problems 

developed for use with this text.  Examples can also be opened with the Open command 
in the File menu. 

o The Help menu provides access to the on-line help. 
o To select a command, place the cursor on the desired menu title, press the mouse button, 

and while holding the button down, slide the cursor to the command you wish to execute; 
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then release the mouse button.  Menus (or commands within a menu) which are not 
presently accessible are dimmed, as, for example, Specify in the menu bar shown above.  
Dimmed items can not be selected.   

 
Online Help for any command in the pull-down menus can be obtained by first pressing and 
holding the mouse button down with the cursor positioned on the menu item and then pressing 
the F1 key. 
 
An example problem is a steady-state heat transfer analysis of a furnace wall shown in Figure 
A.4-1.  The air within the furnace is maintained at 560°C.  The outside surface of the furnace is 
exposed to air at 30°C.  The furnace wall is made of brick.  The problem is to determine the 
temperature distribution in the brick wall and the total rate of heat transfer through the wall.   
 

 
Figure A.4-1: Furnace wall. 

 
By default, FEHT is configured for steady-state heat transfer problems in Cartesian coordinates.  
These characteristics apply to this practice problem and do not need to be changed.  It is usually 
best to set the unit system, scale, and grid spacing at the start of a problem although they can be 
changed at any time.  Pull down the Setup menu and select the Scale and Size command which 
will bring up a dialog window (Figure A.4-2) in which the scale attributes can be entered. 
 
The small circles in the Scale and Size dialog window shown below are called radio buttons.  
Radio buttons control the unit system for heat transfer problems.  To change the unit system, 
move the mouse to position the cursor on the appropriate button and click the mouse button; as 
usual, we will select SI units.  A reasonable scale for this problem is to have 1 cm on the screen 
represent 0.25 m.  Any item within a box can be changed.  The unit for length is, by default, 
centimeters but it can be set to mm, cm, m, or km by clicking in the units box to the right of the 
scale value.  (In the English system, the length unit can be inches, feet, yards, or even miles.)  
Click in the scale units box until it displays m for meters.   Then enter 0.25 in the scale edit box.  
Note that double-clicking within any edit box causes the characters to be highlighted (shown in 
inverse).  Typing any character will replace the highlighted field with the entered character.  X0 
and Y0 designate the location of the origin of the coordinate system on the screen in screen 
coordinates.  The default values, X0=0.0, Y0=0.0 correspond to the origin being placed at the 
lower left of the screen.  Gridlines make the drawing easier to prepare.  Grid spacing is specified 
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in the same coordinates as for the drawing.  Set the grid spacing as shown below.  Click the OK 
button or press the Enter key to set these scale attributes.  
 

 
Figure A.4-2: Scale and Size dialog window 

 
The first step is to sketch material outlines.  It is easier to prepare a scale drawing with a 
coordinate grid.  Select Show Grid from the Display menu (if it is not already selected).  Select 
Outline from the Draw menu.  Since this problem is symmetrical, we only need to analyze one 
quarter of the furnace.  Note that the x and y coordinates of the cursor position for the selected 
unit system and scale are shown in the small window at the upper left, just below the menu bar.  
Move the mouse to locate the cursor at position x=0.50 m, y=2.50 m (Note that because the 
mouse position is represented in discrete pixels, it may not be possible to have the cursor 
positioned exactly at the desired position.  In this case, just place the cursor close to the desired 
position.  It is possible to enter the exact node coordinates with the Boundary Conditions 
command in the Specify menu.)  
 
Click the mouse to fix a node at the corner.  The first node is shown as a small closed circle.  
Now, position the cursor at x=3.00 m, y=2.50 m and click the mouse.  Hold the shift key down to 
provide a drawing aid for horizontal, vertical, or 45° lines.  Click on the remaining corners at 
x=3.00 m, y=0.50 m; x=2.00 m, y=0.50 m; x=2.00 m, y=1.50 m; and x=0.50 m, y=1.50 m.  Now 
click on the first corner.  The outline must begin and end on the same node without crossing any 
existing lines.  At this point, the outline will flash, indicating that the outlining process is 
completed and the material within the flashing boundary is selected.  The outline number and 
name are shown in the center information window below the menu bar.  The area enclosed by the 
outline is shown in the right information window.  The screen should appear as in Figure A.4-3. 
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Figure A.4-3: Quarter symmetry model of furnace. 

 
A material must be selected (flashing) in order to specify its properties.  A material can be 
selected by clicking the mouse anywhere within it outline;  it is automatically selected just after 
it has been drawn.  Select Material Properties from the Specify menu.  A property dialog box 
will appear with default property names listed on the left.  Choose the material to be brick by 
clicking on Building Brick in the list on the left.  You can choose the pattern which will be used 
to identify the material by holding the mouse button down while the cursor is in the pattern box.  
A pop-up palette will appear with the possible patterns.  The color of the pattern can also be 
selected in the same manner by clicking in the Color box.  The thermal properties of brick are 
displayed.  These properties can be changed to other values.  They may also be entered as a 
function of temperature and position.  Leave the brick properties at their default values.  The 
properties dialog box should now appear as shown in Figure A.4-4. 
 

 
Figure A.4-4: Specify Properties dialog window. 

 
Click the OK button and the screen will be redrawn with the pattern you have chosen identifying 
the material.  
 
Next we will set the boundary conditions.  The vertical line at x=0.50 m and the horizontal line at 
y=0.50 m are lines of symmetry and therefore there is zero heat flow across these lines.  Move 
the cursor to a point near the center of one of these lines and click the button.  The line should 
now be flashing.  Move the cursor to the center of the other line and click.  Both lines should 
now be flashing.  Once a boundary is selected (flashing), the Boundary Conditions menu item 
in the Specify menu becomes accessible.  Select this menu item to bring up the Boundary 
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Conditions dialog window (Figure A.4-5).  Enter 0 (for adiabatic conditions) in the Heat Flux 
box and click the OK button.  A check mark will automatically appear in before the word Heat 
Flux to confirm that you are setting a heat flux boundary condition.  
  

 
Figure A.4-5: Specify Boundary Conditions dialog window. 

 
The two boundary lines are now shown with bold lines and cross-hatching to indicate that the 
boundary conditions have been specified and that the boundary condition is adiabatic.   
 
The inside and outside walls of the brick are convective boundaries.  Click the mouse at a point 
near the center of each outside line causing them to flash.  Again, select Boundary Conditions 
from the Specify menu and enter a convection coefficient of 5 W/m2-K and a fluid temperature 
of 30°C.  The convection boundary information for the inside furnace walls is entered in the 
same manner.  Select both boundaries and again issue the Boundary Conditions command.  
Enter the convection coefficient of 10 W/m2-K and a fluid temperature of 560°C.   
 
At this point, you may first wish to exactly locate the node positions if you were unable to do so 
while drawing with the mouse.  Click on the node at the upper left of the drawing and then select 
the Boundary Conditions command in the Specify menu.  (Note that, as a short cut, you can 
accomplish the same result by double-clicking the mouse on the node.)  The Specify Node 
Temperature dialog window will appear with edit boxes for the node temperature and for the X 
and Y coordinates of the node.  In this case, we wish to alter the coordinates, not the node 
temperature. Enter the coordinates x=0.50 and y=2.50 (Figure A.4-6). FEHT will not let the node 
move to a position which causes existing lines to cross.  Note the FEHT displays the coordinates 
in exponential notation.  The E means ‘time ten to the power of’.  You may wish to repeat this 
process for all of the other nodes so that they are exactly positioned at the proper locations.   
 

 
Figure A.4-6: Specify Node Information dialog window. 
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To complete the problem definition, it is necessary to discretize the brick material into triangular 
elements.  The triangular elements are formed by placing element lines within the material.  The 
positions of these lines and the number of triangular elements are determined by the user.  One 
purpose of FEHT is, in fact, to make it easy to explore the effect of the discretization. 
 
It is easier to construct element lines when the brick pattern is hidden; the pattern can be 
removed by selecting Hide Patterns from the Display menu.  The grid lines are no longer 
needed; select Hide Grid from the Display menu.  Select Element Lines from the Draw menu.  
Move the cursor to the upper left node and click the button.  Now, click at point at x=1 m, y=2.00 
m.  (Note that is it not important to exactly locate the nodes.  Anywhere near this point is fine.)  
A node will be created at this point and an element line will be drawn between the two nodes.  
Continue this process of constructing element lines until the screen appears as shown in Figure 
A.4-7.     
 
You have considerable freedom in selecting your mesh and your mesh does not need match 
Figure A.4-7; however, the following rules apply to manual element line construction: 

o The first end of the line must be on an existing line or node.  A new node will form at this 
point if one is not already there. 

o Element lines can not cross existing lines. 
 
Clicking in the area surrounding the drawing or pressing the Esc key cancels the Element Lines 
command in the Draw menu.  It is only necessary to construct a coarse mesh since the Reduce 
Mesh command in the Draw menu can refine a mesh once it has been constructed. 
 

 
Figure A.4-7: One possible manually generated mesh. 

 
The problem definition is complete.  Select the Calculate command from the Run menu to 
initiate the calculations.  FEHT will first check the problem definition to ensure that the 
distributed materials are properly discretized and all properties and boundary conditions are 
specified.  Any errors detected will be listed in the information window at the upper right of the 
screen, just below the menu bar.  This example problem is assumed to be steady-state.  Had this 
been a transient problem (by selecting Transient from the Setup menu), a dialog box would 
have appeared in which the start, stop and step times would be entered.  If no errors are found, a 
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dialog window will appear indicating that the calculations are in progress (Figure A.4-8).  When 
the calculations have been completed, the dialog box will display the elapsed time and other 
information. 

 
Figure A.4-8: Calculations completed message. 

 
Click the Continue button.  A number of the output display windows in the View menu will now 
be accessible.  The temperatures within the wall can be displayed at each node by selecting 
Temperatures from the View menu (Figure A.4-9). 
 

 
Figure A.4-9: Temperatures at each node. 

 
Temperature can also be displayed as a contour plot by selecting Temperature Contours which 
will bring up the dialog window shown in Figure A.4-10. 
 

 
Figure A.4-10: Temperature Contour Information dialog window. 
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Three types of contour plots are available, a banded plot showing gradations of hot to cold in a 
specified number of sections, a continuous color plot showing temperatures as colors, and a 
contour plot of lines of constant temperatures.  The minimum and maximum values in the 
contour plot can be entered manually or FEHT will automatically find the limits if you click in 
the User/Auto box at the upper left.  Click the OK button or press the enter key to show the 
contour plot (Figure A.4-11). 
  

 
Figure A.4-11: Contour plot 

 
In either the temperature or contour plot output, the temperature at the cursor position will be 
displayed at the upper left of the screen below the menu bar when the mouse button is depressed. 
 
It is possible to determine the total heat flow through the brick wall.  Select Heat Flows from the 
View menu.  The screen will be redrawn with the nodes hidden.  Click on any line segment of 
the inside wall and an arrow will appear indicating the direction of heat flow.  The magnitude of 
the heat flow is shown in the information window at the top of the screen below the menu bar.  
Clicking on adjacent lines forming the inside boundary in a clockwise or counterclockwise 
manner will allow the heat flows to be summed.  Alternatively you can select multiple lines by 
pressing the mouse outside of the material and dragging it while holding the mouse down to 
create a selection rectangle.  All lines that lie completely within the selection rectangle will be 
selected.  After selecting all of the lines, you may wish to group them using the Group command 
in the Draw menu.  Clicking on any one of the lines in a group selects all lines in that group.  For 
one quarter of the problem, the heat flow through the furnace wall is 961.8 W.  The total heat 
flow through all sides of the wall is then 3847.2 W. 
 
Select Input from the View menu to return to the drawing window.  At this point, you may wish 
to explore.  Compare the heat flows on the outside walls of the furnace with that on the inside; 
they should agree.  Try using smaller triangular elements.  FEHT will automatically reduce the 
mesh size for you if you select the Reduce Mesh Size command in the Draw menu.  As the 
mesh is refined the solution should approach some limit indicating that the numerical model has 
converged.  
 
This problem was a steady 2-D problem without convection occurring from the face of the 
material.  If Extended Surfaces is selected from the Subject menu then it becomes possible to 
specify convection from the faces; the problem remains 2-D provided that the material is thin 
enough (as determined using a Biot number).  


